yosityo

アップロード時のエラー

0

MTOS5.02をアップロードしたのですが、初めて見るエラーに困っています。

mt.cgiにアクセスしたら、

Got an error: Base class package "Data::ObjectDriver::Driver::DBI" is empty.
(Perhaps you need to 'use' the module which defines that package first.)

と出てきてしまいます。
データベースは作製したのですが、後は原因としてどんな事がかんがえられますでしょうか。

返信(3)

| 返信する
  • >yosityoさん
    こんにちは。

    Movable TypeのどこかのPerlモジュールの中に、「Data::ObjectDriver::Driver::DBI」モジュールを使っているにも関わらず、「use Data::ObjectDriver::Driver::DBI;」の文が入っていないモジュールがあるというエラーです。

    mt-config.cgiに以下の行を追加すると、より詳しいエラーメッセージが表示されます。それを見れば、どのモジュールが問題かが分かると思います。

    DebugMode 1

  • >壱さん
    こんにちは。

    早速のご回答ありがとうございました。
    あれからもアップしてはエラーがでて、困り果てていたのですが、
    アップロード環境はMacのDreamWeaverCS6でアップしておりましたので、試しにWindowsのDreamWeaverCS5でアップしたところ、何事も無かったかのように無事完了しました。

    このような場合、MacとWindowsの違いやDreamWeaverのバージョンの違いがやはり関係してきてしまうものなのでしょうか。

  • >yosityoさん
    こんにちは。

    はっきりとは分かりませんが、以前にも「Dreamweaverでプラグインをアップロードするとうまくいかなかった」という事例を聞いたことがあります。

返信する


カテゴリグループ

フォーラムカテゴリー

21 76

最新のトピック: 公開終了日の取り消し (2013年10月18日 gsk)

178 552

最新のトピック: ユーザへアカウント発行通知 (2014年1月27日 cmtskt)

143 426

最新のトピック: アイテム・カスタムフィールドの連動 (2013年12月16日 kazuhiro watanabe)

291 819

最新のトピック: 検索についての質問 (2014年1月23日 noble777)

OpenID対応しています OpenIDについて